Blocking incognito even with adult blocking allowed

It seems like whenever I add a website to a blocking app group, any website, say When I actually go to my browser, incognito is blocked and safe search is turned on. This will happen even if the “adult blocking” toggle is turned off. When I only have apps in my app group, and no websites, then this doesn’t happen. My preference would be to only have adult blocking when toggled on on.