Granting access to Screen Time on iOS 16.5 Beta

Hey there—I can’t access the support centre in the app because I can’t get past onboarding, because I can’t grant access to the Screen Time API. I never get the dialog and just see ‘Connecting to Screen Time’ forever.

I’ve tried all manner of configurations (ex. I have a passcode set, and have experimented with various Screen Time settings to see if they’d affect it), but nothing works. It’s not just limited to Opal, I’m also seeing this on Screen Time+ and Refocus. The only thing I think must be broken is that I’m on iOS 16.5 Beta (tried on Beta 1 and Beta 2), but it could be anything else. Do you have any ideas? Is there a good way for me to send a log to you?

Hey ! thanks for your report !
We already identified the issue you are facing, it’s also affecting prior iOS versions, and we reported it to Apple, but no answer from them so far. If you have time, you can report the issue as well by following that link, you can mention our bug report ID there → FB11833456, this would definitely help solving that issue !

In the meantime you can try the following steps that sometime helps:

  • Delete all apps that have requested screentime permissions
  • Force restart you phone instructions
  • Re-install Opal and try to pass the onboarding again

I hope this will help ! Will keep you informed if we hear back from apple


Okay, I spent the afternoon trying to figure this one out and eventually got it working. Erasing the device entirely and restoring from backup works (restoring is optional), under certain conditions.

My guess is that, through whatever mechanism, the Screen Time settings get corrupted at some point. This not only breaks Opal on the device in that it’s corrupted on, but any device that syncs Screen Time settings with it. When a device ‘hosts’ the corruption, you have to erase it to fix it—but if a device has ‘received’ the corruption by syncing with another one, you can fix it by disabling and re-enabling Screen Time.

For example: I erased my iPad, but not my iPhone. Here are some scenarios:

  • Screen Time is off on the iPad, but on on the iPhone: Opal works
  • Screen Time is on on the iPad, and on on the iPhone: Opal doesn’t work
  • Screen Time is on on the iPad, but off on the iPhone: Opal works

(Note that turning Screen Time on will do an initial, unavoidable sync, which will corrupt your settings. The only way to avoid this corruption is to turn Screen Time or syncing off on the corrupted device before you enable it on the other device).

I ultimately erased and restored both devices, and Opal works on both now. Painful, but worthwhile!

1 Like

Thank you very much for conducting such a detailed research; it is extremely valuable :heart_eyes: ! I will include what you discovered in the bug report that we submitted to Apple. Your findings could help them identify the root cause of this issue. Thanks again!

i wonder if ‘erase settings’ would work the same way, i mean: turn off syncing → turn off screen time → erase settings → turn on screen time